n8n: Prior to versions 1.123.33 and 2.17.5, the dynamic-node-parameters endpoints did not verify…
n8n
- Severity
- High, CVSS 7.5
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Record
- CVE-2026-42226
- Affects
- n8n
- Known exploited
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Published
- Record first published by the source
- May 4, 2026
- Source last modified
- June 17, 2026
Description
n8n is an open source workflow automation platform. Prior to versions 1.123.33 and 2.17.5, the dynamic-node-parameters endpoints did not verify whether the authenticated caller was authorized to use a supplied credential reference. An authenticated user with access to a shared workflow could supply a foreign credential ID in the request body, causing the backend to decrypt and use that credential in a helper execution path where the caller also controls the destination URL. This allowed the caller to force the backend to authenticate against attacker-controlled infrastructure using a credential belonging to another user, effectively exfiltrating a reusable API key. The issue is not limited to any single node type; any node that resolves credentials dynamically through these endpoints may be affected. This issue has been patched in versions 1.123.33, 2.17.5, and 2.18.0.
Description quoted from the NVD record.
Who is affected
n8n is a tool for connecting different apps and services and automating tasks between them. This flaw affects n8n versions before 1.123.33 and 2.17.5. It is in the part that loads options for workflow steps while someone edits them, and it can involve any type of step that looks up saved login details this way. A user who is logged in and can open a shared workflow could make n8n use another user's saved login details and send them to a server the attacker controls. That would let the attacker steal a reusable access key. This flaw is rated High.
What to do
- If you or someone on your staff installed and runs n8n, that person should handle the update.
- If an IT provider or vendor manages n8n for your organization, send them this advisory and ask when the update will be done.
- Check which version of n8n you run. If it is a 1.x version, update to
1.123.33or later. - If it is a 2.x version, update to
2.17.5or2.18.0, or a later release. - For any further guidance on this flaw, see the vendor advisory linked on this page.
Analysis written from the source record as of June 17, 2026 and reviewed before publishing.