LiteLLM: From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks…
LiteLLM
More for LiteLLM RSS feed for LiteLLM
- Severity
- Critical, CVSS 9.8
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Record
- CVE-2026-42208
- Affects
- LiteLLM
- Known exploited
- Yes, listed in the CISA Known Exploited Vulnerabilities catalog
- Published
- Record first published by the source
- May 8, 2026
- Source last modified
- October 26, 2026
Description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Description quoted from the NVD record.
Who is affected
LiteLLM, made by BerriAI, is a gateway that sits between your organization's apps and AI language model services. This flaw affects versions 1.81.16 up to, but not including, 1.83.7. It is in the part of the product that checks access keys on incoming requests. An attacker who has not logged in could send a specially crafted web request to the gateway and read data from its database. The attacker might also be able to change that data and get unauthorized access to the gateway and the credentials it manages. This flaw is rated Critical. It is on CISA's Known Exploited Vulnerabilities list, which means attacks using it have been seen.
What to do
- Whoever installed or runs LiteLLM for your organization should check which version is in use. Versions 1.81.16 up to, but not including, 1.83.7 are affected.
- That person should update LiteLLM to version
1.83.7or later as soon as possible. Attacks using this flaw have been seen, and the attacker does not need to log in. - If an IT provider or vendor runs LiteLLM for your organization, send them this advisory and ask when the update will be done.
Analysis written from the source record as of October 26, 2026 and reviewed before publishing.