SA-26-129 High

AnythingLLM: Prior to 1.13.0, the filesystem-search-files agent skill passes its LLM-controlled pattern…

AnythingLLM

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-48116
Affects
AnythingLLM
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
May 28, 2026
Source last modified
July 21, 2026

Description

AnythingLLM is an application that turns pieces of content into context that any LLM can use as references during chatting. Prior to 1.13.0, the filesystem-search-files agent skill passes its LLM-controlled pattern parameter to ripgrep as a positional argument without a -- end-of-options separator. ripgrep parses any argument that starts with - as an option, so a pattern of --pre=/bin/sh turns ripgrep into a script executor: it runs /bin/sh <file> for every file it walks. An attacker who can chat with an agent on a deployment with the filesystem plugin enabled (the default in the official Docker image) can use this, together with the sibling filesystem-write-text-file skill, to run arbitrary commands inside the AnythingLLM server container. This vulnerability is fixed in 1.13.0.

Description quoted from the NVD record.

Who is affected

AnythingLLM, made by Mintplex Labs, is an app that lets people chat with AI language models using your organization's own documents as reference. This flaw affects versions before 1.13.0. The problem is in the agent's file search skill, a feature that lets the AI assistant search files. It matters when the file tools for agents are turned on, which is the default in the official Docker package. Anyone who can chat with an agent could use this, together with the agent's file writing skill, to run any commands they choose inside the AnythingLLM server. This flaw is rated High.

What to do

  1. The person who installed or runs AnythingLLM for your organization should check which version is in use, including any copy set up from the official Docker package.
  2. If the version is older than 1.13.0, update it to 1.13.0, which fixes this flaw.
  3. If an IT provider or vendor runs AnythingLLM for your organization, send them this advisory and ask when the update to 1.13.0 will be done.
  4. After updating, check that the version shown is 1.13.0 or later, so you know the fix is in place.

Analysis written from the source record as of July 21, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all