SA-26-170 High

LiteLLM: M2M JWT Handler Has Improper Authorization

LiteLLM

Severity
High, CVSS 7.5
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-12771
Affects
LiteLLM
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
June 21, 2026
Source last modified
October 25, 2026

Description

A vulnerability was identified in BerriAI litellm up to 1.82.2. This affects an unknown function of the file litellm/proxy/auth/user_api_key_auth.py of the component M2M JWT Handler. Such manipulation leads to improper authorization. The attack can be launched remotely. A high complexity level is associated with this attack. The exploitability is reported as difficult. The exploit is publicly available and might be used. The vendor was contacted early about this disclosure.

Description quoted from the NVD record.

Who is affected

LiteLLM, made by BerriAI, is a tool that sits between your organization's apps and AI language model services and passes requests between them. This flaw affects versions up to 1.82.2. It is in the part that checks sign-in tokens used when one computer system connects to another without a person logging in. An attacker could use it remotely to get access they should not have, although the attack is difficult to carry out. This flaw is rated High.

What to do

  1. If you or your staff installed and run LiteLLM, the person who looks after it should check which version your organization is using.
  2. No fixed version is named for this flaw yet, so check the vendor advisory linked on this page for a fixed release. If you run version 1.82.2 or earlier, install that release as soon as it is available.
  3. If an IT provider or vendor runs LiteLLM for your organization, send them this advisory and ask when the update will be done.

Analysis written from the source record as of October 25, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all