SA-26-179 High

Langflow: A vulnerability was identified in langflow-ai langflow up to 1.9.3

Langflow

Severity
High, CVSS 7.8
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-12822
Affects
Langflow
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
June 22, 2026
Source last modified
October 25, 2026

Description

A vulnerability was identified in langflow-ai langflow up to 1.9.3. This affects an unknown function of the component Bundle URL Loader. The manipulation leads to code injection. The attack needs to be performed locally. The vendor was contacted early about this disclosure but did not respond in any way.

Description quoted from the NVD record.

Who is affected

Langflow is a tool for building apps that use AI language models. This flaw affects Langflow versions up to and including 1.9.3. The problem is in the part of the product that loads bundles from a web address. Someone who can already work on the computer where Langflow runs could misuse this part to make Langflow run code of their choosing. The attack has to be carried out locally, meaning on that same machine. This flaw is rated High.

What to do

  1. If you or a staff member installed or runs Langflow, that person should handle this. If an IT provider or vendor runs it for your organization, send them this advisory and ask when the update will be done.
  2. No fixed version is named for this flaw yet, so check the vendor advisory linked on this page for a fixed release.
  3. When a fixed release is available, update every copy of Langflow running version 1.9.3 or earlier to that release.

Analysis written from the source record as of October 25, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all