SA-26-284 High

Weaviate: Weaviate before 1.38.0 does not verify that a principal performing an RBAC role assignment holds…

Weaviate

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-59093
Affects
Weaviate
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
July 2, 2026
Source last modified
July 14, 2026

Description

Weaviate before 1.38.0 does not verify that a principal performing an RBAC role assignment holds the permissions granted by the assigned role. The assignRoleToUser and assignRoleToGroup handlers (POST /authz/users/{id}/assign and /authz/groups/{id}/assign) authorize only that the caller may assign roles to the target user or group, not the permissions contained in the assigned roles, unlike role creation which enforces that a user can only create roles with permissions less than or equal to its own. A user holding only the delegated assign_and_revoke_users or assign_and_revoke_groups permission can assign the built-in admin role, or any high-privilege custom role, to itself or others, escalating to full administrative control of the database.

Description quoted from the NVD record.

Who is affected

Weaviate is a database that stores information so AI tools can search it by meaning. This flaw affects versions before 1.38.0, in the part of the product that controls user roles and permissions. When someone has been allowed only to assign roles to users or groups, Weaviate does not check whether that person already holds the powers inside the role being handed out. Such a user can give the built-in admin role, or any other powerful role, to themselves or to others and take full administrative control of the database. This flaw is rated High.

What to do

  1. If you are not sure whether your organization uses Weaviate, ask the person or provider who looks after your computers and online services.
  2. Ask whoever runs Weaviate to check which version is in use, because only versions before 1.38.0 have this flaw.
  3. If someone in your organization installed or runs Weaviate, ask them to update it to version 1.38.0 or later, which fixes this flaw.
  4. If an IT provider or vendor runs Weaviate for your organization, send them this advisory and ask when the update will be done.

Analysis written from the source record as of July 14, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all