SA-26-335 Critical

Open WebUI: Open-webui before 0.3.14 contains a cross-origin resource sharing misconfiguration allowing…

Open WebUI

Severity
Critical, CVSS 9.6
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Record
CVE-2026-56400
Affects
Open WebUI
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
July 15, 2026
Source last modified
July 16, 2026

Description

open-webui before 0.3.14 contains a cross-origin resource sharing misconfiguration allowing arbitrary origins with allow_origins=* and authenticated requests to the /api/v1/functions endpoint. Attackers can execute arbitrary code on the openwebui instance by crafting malicious cross-site requests from attacker-controlled websites when an admin user visits them.

Description quoted from the NVD record.

Who is affected

Open WebUI is a chat interface that people use through a web browser. This flaw affects versions before 0.3.14. A setting in the product lets any outside website send requests to it as if they came from a logged-in user, including requests to the part of the product that handles functions. If an admin user of your Open WebUI visits a website controlled by an attacker, that website can make your Open WebUI run any code the attacker chooses. This flaw is rated Critical.

What to do

  1. Find out who installed or runs Open WebUI for your organization. This is usually the person who set it up, or the IT provider or vendor who manages it for you.
  2. If someone in your organization runs it, that person should check which version is installed and, if it is older than 0.3.14, update it to 0.3.14 or later.
  3. If an IT provider or vendor runs Open WebUI for you, send them this advisory and ask when the update will be done.
  4. Check the vendor advisory linked on this page for the update steps for your setup.

Analysis written from the source record as of July 16, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all