SA-26-406 High

Flowise: Flowise RCE via TypeORM DataSource

Flowise

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-69251
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 4, 2026
Source last modified
September 14, 2026

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise record manager and agent memory nodes allowed users to set arbitrary TypeORM DataSource options through the additionalConfig input in packages/components/nodes/recordmanager/MySQLRecordManager/MySQLrecordManager.ts, packages/components/nodes/recordmanager/PostgresRecordManager/PostgresRecordManager.ts, packages/components/nodes/recordmanager/SQLiteRecordManager/SQLiteRecordManager.ts, packages/components/nodes/memory/AgentMemory/MySQLAgentMemory/MySQLAgentMemory.ts, and packages/components/nodes/memory/AgentMemory/AgentMemory.ts. TypeORM DataSource options such as entities, subscribers, and migrations can load local JavaScript files, allowing an authenticated user to execute arbitrary code on the server by uploading a JavaScript payload and referencing it from additionalConfig.entities. This issue is fixed in version 3.1.3.

Description quoted from the NVD record.

Who is affected

Flowise is a drag and drop tool for building apps that use AI language models. This flaw affects versions before 3.1.3. The problem is in the building blocks that keep track of stored data and give AI agents memory, which let users add extra database connection settings with no limits on which settings. Someone who can log in to Flowise could upload a harmful program file and use those settings to make the server run it, which would let them run any code they choose on the server. This flaw is rated High.

What to do

  1. Find out who installed or runs Flowise for your organization: someone on your staff, or an IT provider or vendor who manages it for you.
  2. If your organization runs Flowise itself, the person who installed it should check which version is in use. Any version before 3.1.3 is affected by this flaw.
  3. That person should update Flowise to version 3.1.3 or later, which fixes this flaw.
  4. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update to 3.1.3 will be done.

Analysis written from the source record as of September 14, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all