SA-26-407 High

Flowise: Missing authorization on `/api/v1/files` allows low-privileged API keys to list and delete files…

Flowise

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-69252
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 4, 2026
Source last modified
October 23, 2026

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the /api/v1/files route was protected only by the feat:files feature gate and did not enforce checkPermission on GET or DELETE. A low-privileged authenticated API key with unrelated permissions could call GET /api/v1/files to list files under the organization storage root and DELETE /api/v1/files?path=... to delete files belonging to other workspaces in the same organization because getAllFiles and deleteFile used activeOrganizationId and a user-controlled path without restricting access by permissions or activeWorkspaceId. This issue is fixed in version 3.1.3.

Description quoted from the NVD record.

Who is affected

Flowise is a drag-and-drop tool for building apps that use AI language models. This flaw affects versions before 3.1.3. The part of the product that manages stored files does not check whether an access key (a key that lets people or other programs connect to Flowise) is allowed to use it. Anyone holding a valid access key with only limited, unrelated permissions could see a list of files stored for your whole organization. They could also delete files that belong to other workspaces in the same organization. This flaw is rated High.

What to do

  1. Find out who looks after Flowise for your organization: the person who installed or runs it, or the IT provider or vendor who manages it for you.
  2. If that person is on your staff or a volunteer, ask them to check which version of Flowise is running. Any version before 3.1.3 has this flaw.
  3. Have them update Flowise to version 3.1.3 or later, which fixes this flaw.
  4. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update will be done.

Analysis written from the source record as of October 23, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all