SA-26-408 High

Flowise: Flowise Sandbox Escape to RCE

Flowise

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-69253
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 4, 2026
Source last modified
October 23, 2026

Description

Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to version 3.1.3, several custom-tool components — AgentAsTool, ChatflowTool, and ExecuteFlow — ran code in the in-process  vm2  sandbox. To build that code, they inserted a user-controlled  baseURL  value straight into the JavaScript source, for example  const url = "${baseURL}/..."; . The only check on  baseURL  was  isValidURL , but a valid-looking URL can still contain characters that break out of a code string. An authenticated user could craft a  baseURL  that passed this check, closed the surrounding string, and injected their own JavaScript into the sandboxed script (code injection, CWE-94). The  vm2  sandbox runs in the same Node.js process as Flowise and exposes risky dependencies. As a result, the injected code could escape the sandbox and run arbitrary code on the Flowise server as the Flowise process user. Exploitation only requires an authenticated session. The issue is fixed in version 3.1.3, which passes the URL to the sandbox as data instead of inserting it into code and adds stricter URL validation.

Description quoted from the NVD record.

Who is affected

Flowise is a drag-and-drop tool for building apps that use AI language models. This flaw affects all versions before 3.1.3. The problem is in several of the building blocks used to add custom tools to a flow. Anyone with a login to your Flowise installation could misuse a web address setting in these building blocks to slip in their own code. That code could break out of the protective container meant to hold it and run any code they like on the server that hosts Flowise, with the same access Flowise itself has. This flaw is rated High.

What to do

  1. Find out who runs Flowise for your organization. It may be the person who installed it, or an IT provider or vendor who manages it for you.
  2. If your own staff or volunteers run it, they should update Flowise to version 3.1.3 or later. This version fixes the flaw.
  3. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update will be done.
  4. The person doing the update can find update instructions in the vendor advisory linked on this page.

Analysis written from the source record as of October 23, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all