Flowise: SSRF Protection Bypass via IPv4-Mapped IPv6 Addresses
Flowise
More for Flowise RSS feed for Flowise
- Severity
- High, CVSS 8.6
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- Record
- CVE-2026-69257
- Affects
- Flowise
- Known exploited
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Published
- Record first published by the source
- August 4, 2026
- Source last modified
- October 24, 2026
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise's HTTP security module httpSecurity.ts did not normalize IPv4-mapped IPv6 addresses such as ::ffff:127.0.0.1 and ::ffff:169.254.169.254 before checking them against the deny list. Because ipaddr.js reports these addresses as ipv6 while IPv4 CIDR deny-list entries are ipv4, isDeniedIP() skipped the IPv4 CIDR checks. An attacker who controls DNS resolution for a hostname used by the HTTP Node, API Chain, Document Loader, MCP tool, or other paths using secureAxiosRequest(), secureFetch(), or checkDenyList() could return a AAAA record for an IPv4-mapped target and cause requests to reach localhost, internal services, or cloud metadata endpoints. This issue is fixed in version 3.1.3.
Description quoted from the NVD record.
Who is affected
This flaw affects Flowise, a drag-and-drop tool for building apps that use AI language models. Versions before 3.1.3 are affected. Flowise has a safety check meant to stop its workflows from contacting private or internal addresses, but the check could be fooled when such an address was written in a different format. An attacker who controls how a website name is looked up could use parts of a workflow that contact other web services, load documents or connect to outside tools to reach the Flowise server, other internal systems, or cloud metadata services (where cloud servers keep information about themselves). This flaw is rated High.
What to do
- Find out who installed or runs Flowise for your organization. If you are not sure whether you use it, ask whoever looks after your computers and online tools.
- If you or someone on your staff runs Flowise yourselves, update it to version
3.1.3or later. Versions before3.1.3have this flaw. - If an IT provider or vendor runs Flowise for your organization, send them this advisory and ask when the update to version
3.1.3will be done. - After updating, have the person who did it check that Flowise shows version
3.1.3or later.
Analysis written from the source record as of October 24, 2026 and reviewed before publishing.