SA-26-413 Critical

Flowise: Unauthenticated Property Injection into Flow Execution Context via Ungated `overrideConfig`…

Flowise

Severity
Critical, CVSS 9.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Record
CVE-2026-69258
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 4, 2026
Source last modified
October 24, 2026

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the unauthenticated POST /api/v1/prediction/:id endpoint accepted an overrideConfig object and unconditionally spread it into internal flowConfig and flowData objects in packages/server/src/utils/buildChatflow.ts and packages/server/src/utils/index.ts without checking apiOverrideStatus. This allowed unauthenticated attackers to inject arbitrary properties into the flow execution context of any public chatflow, overwrite values such as chatId, sessionId, and chatHistory, and control values resolved through $flow.* template variables consumed by flow nodes. This issue is fixed in version 3.1.3.

Description quoted from the NVD record.

Who is affected

Flowise is a drag-and-drop tool for building apps that use AI language models. This flaw affects versions before 3.1.3. It is in the part of Flowise that answers incoming chat requests for any public chatflow (a chatbot or AI workflow that anyone can reach without logging in). Someone with no login could slip their own settings into how that chatflow runs, overwrite the conversation's identifiers and its chat history, and control values that the flow's building blocks use. This flaw is rated Critical.

What to do

  1. Find out who installed or runs Flowise for your organization: someone on your staff, a volunteer, or an outside IT provider.
  2. If that person is on your team, have them check which version is running. Any version before 3.1.3 is affected.
  3. Have them update Flowise to version 3.1.3 or later, which fixes this flaw. Give this priority if you have any public chatflows, since those are the ones this flaw exposes.
  4. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update to 3.1.3 will be done.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all