SA-26-415 High

Flowise: `DELETE /api/v1/chatflows/:id` does not validate resource type, allowing `agentflows:delete` and…

Flowise

Severity
High, CVSS 8.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Record
CVE-2026-69262
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 4, 2026
Source last modified
October 24, 2026

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, DELETE /api/v1/chatflows/:id authorized requests with checkAnyPermission('chatflows:delete,agentflows:delete'), so possession of either permission was sufficient to reach the delete path. The delete logic then resolved the target record only by id and workspaceId and did not validate the target resource type, allowing a caller with only agentflows:delete to delete a CHATFLOW and a caller with only chatflows:delete to delete an AGENTFLOW in the same workspace. This issue is fixed in version 3.1.3.

Description quoted from the NVD record.

Who is affected

Flowise, a drag-and-drop tool for building apps that use AI language models, has this flaw in all versions before 3.1.3. Flowise lets you give users permission to delete either chatflows (chat assistants) or agentflows (automated AI agents) separately. Because of this flaw, a signed-in user who is only allowed to delete one kind can also delete the other kind within the same workspace. This means someone with limited delete rights could remove chat assistants or agents they were not meant to touch. This flaw is rated High.

What to do

  1. If you or a staff member installed and run Flowise yourselves, the person who looks after it should update Flowise to version 3.1.3 or later.
  2. If an IT provider or vendor runs Flowise for your organization, send them this advisory and ask when the update to version 3.1.3 will be done.
  3. If you are not sure which version you are running, ask the person who installed Flowise to check. Any version before 3.1.3 has this flaw and needs the update.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all