Flowise: Cross-Workspace OAuth2 Credential Metadata Leak
Flowise
More for Flowise RSS feed for Flowise
- Severity
- High, CVSS 8.1
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Record
- CVE-2026-70474
- Affects
- Flowise
- Known exploited
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Published
- Record first published by the source
- August 4, 2026
- Source last modified
- October 24, 2026
Description
Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to 3.1.3, Flowise has three OAuth2 credential endpoints that look up credentials by id alone with no workspaceId filter. The authorize, callback, and refresh handlers query the Credential table by id only; callback and refresh are whitelisted from authentication. This allows any authenticated user to initiate OAuth2 flows against credentials belonging to other workspaces, allows an unauthenticated attacker to forge OAuth2 callbacks to overwrite tokens in any credential, and allows an unauthenticated attacker to refresh tokens for any credential. The affected routes include /api/v1/oauth2-credential/authorize/<VICTIM_CREDENTIAL_UUID>, /api/v1/oauth2-credential/callback?code=ATTACKER_AUTH_CODE&state=<VICTIM_CREDENTIAL_UUID>, and /api/v1/oauth2-credential/refresh/<VICTIM_CREDENTIAL_UUID>. This issue is fixed in version 3.1.3.
Description quoted from the NVD record.
Who is affected
Flowise is a drag-and-drop tool for building apps that use AI language models. This flaw affects Flowise versions before 3.1.3, in the part that handles saved credentials used to connect to other online services through a standard sign-in method called OAuth2. That part does not check which workspace a credential belongs to. Because of this, any logged-in user could start a sign-in process using another workspace's credentials. Someone with no login at all could fake the final sign-in step to overwrite the access keys stored in any credential, or refresh the keys of any credential. This flaw is rated High.
What to do
- The person who installed or runs Flowise for your organization should find out which version is in use. Any version before
3.1.3has this flaw. - That person should update Flowise to version
3.1.3, which fixes this flaw. Plan the update soon, because parts of this flaw can be used by someone with no login. - If an IT provider or vendor runs Flowise for your organization, send them this advisory and ask when the update to version
3.1.3will be done.
Analysis written from the source record as of October 24, 2026 and reviewed before publishing.