SA-26-491 High

n8n: N8n versions before 1.123.67, 2.31.5, and 2.32.1 contain an arbitrary file write vulnerability…

n8n

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-72762
Affects
n8n
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 11, 2026
Source last modified
October 24, 2026

Description

n8n versions before 1.123.67, 2.31.5, and 2.32.1 contain an arbitrary file write vulnerability in the Edit Image node, which passes its output format parameter to the underlying image library without validation. An authenticated user able to run workflows can supply a crafted format value to write arbitrary files outside the node's working directory on the n8n instance.

Description quoted from the NVD record.

Who is affected

This flaw affects n8n, a tool for connecting apps and automating routine tasks through workflows. It affects versions before 1.123.67, 2.31.5, and 2.32.1. The problem is in the Edit Image building block, which lets a workflow change pictures. Someone who has an account and is allowed to run workflows could use it to write any files they choose onto the computer running n8n, outside the area that building block is meant to use. This flaw is rated High.

What to do

  1. The person who installed or runs n8n for your organization should find out which version is in use, since versions before the fixed ones have this flaw.
  2. Update n8n to a fixed version: 1.123.67, 2.31.5 or 2.32.1, whichever matches the release you are on, or any later version.
  3. If an IT provider or vendor runs n8n for your organization, send them this advisory and ask when the update will be done.
  4. For details on each fixed release, see the vendor advisory linked on this page.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all