SA-26-506 High

Flowise: Flowise before 3.1.3 contains a sandbox escape vulnerability in pythonCodeValidator.ts that…

Flowise

Severity
High, CVSS 8.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Record
CVE-2026-73484
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 13, 2026
Source last modified
October 24, 2026

Description

Flowise before 3.1.3 contains a sandbox escape vulnerability in pythonCodeValidator.ts that fails to block native Pandas DataFrame methods like to_csv, to_json, pipe, and query. Authenticated attackers can exploit this to exfiltrate uploaded CSV data or write arbitrary files to the server filesystem.

Description quoted from the NVD record.

Who is affected

Flowise is a tool for building apps that use AI language models. This flaw affects versions before 3.1.3. A safety check meant to limit what Python code can do when working with uploaded spreadsheet files (CSV files) does not block certain built-in data commands. Someone who has a login to your Flowise system could use this to copy out the contents of uploaded CSV files or write any files they choose onto the server running Flowise. This flaw is rated High.

What to do

  1. Find out who installed and runs Flowise for your organization. If it is someone on your staff, that person should handle this flaw.
  2. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update will be done.
  3. Update Flowise to version 3.1.3 or later, which fixes this flaw.
  4. After the update, check that the version shown in Flowise reads 3.1.3 or later on every system where it is installed.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all