SA-26-508 High

Flowise: Flowise before 3.1.3 contains a code injection vulnerability in the CSV Agent node's…

Flowise

Severity
High, CVSS 8.8
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Record
CVE-2026-73486
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 13, 2026
Source last modified
October 24, 2026

Description

Flowise before 3.1.3 contains a code injection vulnerability in the CSV Agent node's customReadCSV parameter that allows authenticated attackers to execute arbitrary Python code. The validator uses a static regex blocklist that can be bypassed through obfuscation techniques, enabling attackers to execute code in the unsandboxed pyodide environment with full system access.

Description quoted from the NVD record.

Who is affected

Flowise, a tool for building apps and workflows that use AI language models, has a flaw in versions before 3.1.3. The problem is in the CSV Agent building block, which lets a workflow work with spreadsheet data in CSV files. Someone who has a login to your Flowise could get past its safety check and make it run any Python code (program instructions) they choose. That code runs without being walled off, with full access to the computer system Flowise runs on. This flaw is rated High.

What to do

  1. Find out who installed or runs Flowise for your organization: a staff member, a volunteer, or an IT provider. They are the person who should act on this flaw.
  2. If you run Flowise yourself, update it to version 3.1.3 or later, which fixes this flaw.
  3. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update to 3.1.3 will be done.
  4. Check the vendor advisory linked on this page for any further guidance about this flaw.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all