SA-26-512 Critical

Flowise: Flowise before 3.1.3 contains a sandbox escape vulnerability in the vm2 JavaScript sandbox that…

Flowise

Severity
Critical, CVSS 9.9
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Record
CVE-2026-73602
Affects
Flowise
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 13, 2026
Source last modified
October 24, 2026

Description

Flowise before 3.1.3 contains a sandbox escape vulnerability in the vm2 JavaScript sandbox that allows authenticated users to execute arbitrary code by exploiting moment locale validation bypass. Attackers can craft a fake String object with a match function that bypasses path traversal checks to load and execute malicious JavaScript files stored in the document store outside the sandbox.

Description quoted from the NVD record.

Who is affected

Flowise is a tool for building apps that use AI language models. This flaw affects versions before 3.1.3. It is in the protected area Flowise uses to run custom code safely, often called a sandbox. Someone who can sign in to your Flowise could break out of that protected area and run any code they choose on the computer that hosts Flowise, by loading harmful files kept in the product's document store. This flaw is rated Critical.

What to do

  1. Find out who looks after Flowise for your organization. This is usually the person who installed it or runs it, or an IT provider or vendor who manages it for you.
  2. If someone in your organization runs Flowise, they should check which version is installed and update it to version 3.1.3 or later as soon as possible.
  3. If an IT provider or vendor runs Flowise for you, send them this advisory and ask when the update will be done.
  4. For full details of the fixed release, see the vendor advisory linked on this page.

Analysis written from the source record as of October 24, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all