SA-26-542 High

n8n: N8n before 1.123.69, 2.x before 2.33.4, and 2.x before 2.34.1 contain an allowed-domains bypass…

n8n

Severity
High, CVSS 7.1
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Record
CVE-2026-77081
Affects
n8n
Known exploited
Not listed in the CISA Known Exploited Vulnerabilities catalog
Published
Record first published by the source
August 20, 2026
Source last modified
September 1, 2026

Description

n8n before 1.123.69, 2.x before 2.33.4, and 2.x before 2.34.1 contain an allowed-domains bypass in the GraphQL node. When the node's Authentication parameter is set to expression mode, every authentication-gated credential selector is treated as active; if two credentials of different types are attached, the node enforces the allowed-domains policy of only the first credential while still attaching material from both. An authenticated user with workflow-authoring rights can thereby send a domain-restricted credential to an attacker-controlled endpoint, exfiltrating it with the leaked credential's permissions.

Description quoted from the NVD record.

Who is affected

n8n is a tool for automating tasks by connecting different apps and services. This flaw affects n8n versions before 1.123.69, and 2.x versions before 2.33.4 and before 2.34.1. The problem is in a building block that lets a workflow send queries to other web services. When its sign-in setting is written as a formula (expression mode) and two saved logins of different types are attached, only the first login's list of allowed web addresses is enforced. A signed-in user who can build workflows could send a restricted saved login to a server they control and use its access. This flaw is rated High.

What to do

  1. If someone in your organization installed and runs n8n, that person should check which version is running.
  2. If an IT provider or vendor runs n8n for your organization, send them this advisory and ask when the update will be done.
  3. Update n8n to version 1.123.69 or later on the 1.x line. On the 2.x line, update to 2.33.4 or 2.34.1 or later, as listed in the vendor advisory linked on this page.
  4. After updating, check again that the running version is one of the fixed versions above.

Analysis written from the source record as of September 1, 2026 and reviewed before publishing.

Sources

MORE ADVISORIES

See all