vLLM: A flaw has been found in vllm-project vLLM up to 0.26.0
vLLM
More for vLLM RSS feed for vLLM
- Severity
- High, CVSS 7.5
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Record
- CVE-2026-103241
- Affects
- vLLM
- Known exploited
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Published
- Record first published by the source
- September 30, 2026
- Source last modified
- October 6, 2026
Description
A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.
Description quoted from the NVD record.
Who is affected
vLLM is software that runs AI language models on a server so that other apps and people can send them questions and get answers. This flaw affects vLLM versions up to 0.26.0, in a part of the product that handles Gemma 4 AI models. An attacker could exploit it remotely, over a network, and cause a denial of service: vLLM could stop responding, so the people and tools that rely on it lose access. This flaw is rated High.
What to do
- If you or someone on your staff installed vLLM and runs it, that person should handle this. If an IT provider or vendor runs it for your organization, send them this advisory and ask when the update will be done.
- Find out which version of vLLM you are running. Any version up to
0.26.0has this flaw. - Upgrade vLLM to version
0.29.1rc0, which is the fix named for this flaw. Upgrading the affected part of the product is the recommended action.
Analysis written from the source record as of October 6, 2026 and reviewed before publishing.